Simon Says login not working

Discussion in 'Simon Says Affiliates' started by melcb, Apr 16, 2014.

  1.  
    melcb

    melcb Administrator Staff Member

    Messages:
    21
    Likes Received:
    44
    Joined:
    Apr 16, 2014
    I tried to login to the affiliate program and redirects to page that says:
    This web page is not available

    I just need confirmation is these guys are still operating. Anybody have an update on these guys?
     
  2.  
    KasinoKing

    KasinoKing Player turned affiliate.

    Messages:
    2,593
    Likes Received:
    816
    Joined:
    Aug 10, 2009
    I'm getting the same thing. But it could be just a temporary glitch. (Seen this before with other programs).

    Mind you, I stopped promoting them last year along with several other Rival White Labels who seem to have fallen into a huge Black Hole somewhere. Tried contacting them in August - no response. :(
    It's shame, because they were one of the first dozen Rivals ever to open and I used to do quite well with them back in the day.

    My advise to my fellow affiliates now though, is "don't go there".

    KK
     
  3.  
    tryme1

    tryme1 Affiliate Guard Dog Member

    Messages:
    681
    Likes Received:
    56
    Joined:
    Mar 2, 2009
    I've never promoted Simon Says, but have to agree with KasinoKing - there were (probably still are) 100s of these Rival white labels and they should all be avoided. They're under-manned, under-funded and can't provide an appropriate level of service or support to either players or affiliates. So, why bother.
     
  4.  
    melcb

    melcb Administrator Staff Member

    Messages:
    21
    Likes Received:
    44
    Joined:
    Apr 16, 2014
    Thanks for your responses KasinoKing and tryme1. I totally agree with what you two say regarding the Rival white labels! Have added a warning for our players until we know for sure if the casino is closed or the affiliate program has ceased operating.

    I tried again this morning and was able to sign into the affiliate account. Seems to load OK after trying to login the second time.
     

Share This Page